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Getting Started

DRRC Data Manager
In order to effectively install Caribeviz you will need to first install DRRC Data Manager. A

crucial component of the software is an add-in called tomcat which relies on Java Virtual
Machine to run. Verify if your unit has Java installed using

https://java.com/en/download/installed.isp

Browsers such as Chrome are not Java enabled so you may have to use either Safari or

Internet Explorer in order to facilitate the download of Java.

Copy the file directory for the Java program as it will be required during the installation of

Tomcat. You may also select the file path using the drop down available when prompted.

Having installed tomcat ensure the run option is selected as this is required for the installation

of subsequent components of DRRC Data Manager (Maria DB)

You will be prompted to create a password be sure to select one that you will remember and

ne which has at least 10 characters inclusive of figures. Leave all other boxes unchecked.

Trouble Shooting
DRRC Data Manager is in essence a web application hosted on the Tomcat virtual server.

Successful installation of Tomecat relies heavily on how quickly the software can
communicate with the server hosting the data. Save for instances wherein a fast internet

connection is available you will need to manually tell the program where to look for the data.

Go to C:\Program Files\Apache Software Foundation\Tomcat 8.0\webapps and manually

copy the root.war file into the ROOT folder. This function requires administrative privileges,
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contact your IT department. Upon successful install the app can be accessed here

http://localhost:8080 using your browser.

Installing CaribEviz

Launch setup for CaribEviz. The installation of CaribEviz may tax the RAM of your device,

for increased efficiency close all other applications.

When prompted check all components. Providing the installation was successful you should

be able to launch CaribEviz.

Trouble Shooting
Error JAV A was started but returned exit code 1.

Check to ensure the correct version of java was installed 32vs 64bit.

You will need to edit the configuration file within C:\Program Files

(x86)\CaribEViz\caribeviz

Choose run as administrator and input the following

vm

C:/Program Files/Java/jrel.8.0_144/bin/javaw.exe

This should be inputted above the line that says “-vmargs”

If there is no option for run as administrator copy and paste the configuration file to the
desktop and edit it as shown above. Drag and drop back the file into the folder and click
continue as administrator when prompted. Note this requires administrator privileges and as
such those without will need the help of someone within the organisation that has such

privileges such as an IT rep.
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It is useful to modify the permissions for CaribEviz which allow for efficient trouble shooting

should the need arise.

Permissions for CaribEViz X
Security
Object name:  C:\Program Files (x86)\CaribEViz\carbeviz\CarbE'

Group or user names:

[[E ALL APPLICATION PACKAGES

(= ALL RESTRICTED APPLICATION PACKAGES

S8 SYSTEM

S Administrators (DESKTOP-UASMH21\Administrators)
SR Users (DESKTOP-UASMH31\Users)

——— r.‘, R ‘,m.—'....‘_.v.:

{ Add.. || Remove

Permissions for ALL
APPLICATION PACKAGES
Full control

Modify

Read & execute

Read

Write

Useful links
https://www.youtube.com/watch?v=JCVnysH4V0I

http://troubleshooter.xyz/wiki/fix-java-was-started-but-returned-exit-code-1/

https://java.com/en/download/manual.isp
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Launching CaribEviz

Getting to Know the Software

Having successfully installed CARIBEVIZ you will be able to access the welcome tab. Click
on each tab and you will be directed to the associated webpage within the app. Navigation of

the tabs may be achieved using the arrows at the top right hand of the screen.
There are three tabs available:

e The Overview Tab provides a general description of the functionalities of Ergo EQ as
well as a few tutorials related to CaribEviz.
e The Tutorial Tab provides step by step introduction to the capabilities of the software.

e The Workbench tab launches the program.

(@ CoribEViz - o x
File Edit Reports Dataset Scenaio Vindow Help

& |4 Welcome 1 o & s xE TS|
- B

il  Welcome to Ergo EQ :: CaribEViz

L)

— ‘Workbench

The welcome tab once closed will no longer auto populate but can be restored using

help=>welcome.
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If the Tutorial Tab fails to connect uselful links may be found here

http://ergo.ncsa.illinois.edu/?page_id=365

The Workbench Tab

B bl - 8 X

@ Canbtvis 52 | C® @ % 4] % = O [ andreTet @D-Swing) 5 |

» @ AndreChest |
> @ AndreChem! |

9 oo 51| W0mlx --0)

Within the workbench of CaribEviz there are four main windows which when combined
facilitates most of the processing capabilities of the software. These windows are namely:

Scenario View, Visualisation View, Data Catalogue View and Style Editor View.
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Scenario View

CaribEViz
File Edit Reports Dataset Scenario Window Help

@ CaribEviz 33 | C#| 8 ¥4|x=0O
|| > @ AndreCheat
» @ AndreCheat1
, @ AndreTest
@ AndreTest1
s (@ Bridge 1

Scenario View provides an overview of all scenarios that have been created thus far within

the software.

Creating a Scenario
In order to create a scenario you will need to click the icon [/ . A window will pop up

prompting you to give the scenario a name. A valid unused name must be inputted.

Descriptions though not mandated will be useful. Click Next.

You will be prompted by the region selector window. Select the region of interest from the
available dropdown list (Country). In some instances you will be able to further define the
region of interest by selecting the drop down beside the selected state, county or city. The
region preview provides a basic outline of the boundary as per the selected region. The final

window should be left with the defaults.
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Create Scenario

Please enter a name and description for this scenario...

Name | Test ~

Author, Institution, or other Description

Options
Use Region of Interest
[A] View on Completion

e | R Next >  Finish  Concdd |

(&) (| X

e

Select a Region of Interest

Please select a region of interest for this scenario...

Region Selector Regions Selected

Kingston

Country !Jarnaica ~

> Kingston city
> [[] Portmore city

> [[] Montege Bay city

> [ Spanish Town city

Region Preview

~>

—

| Hep ][ <Back [ Nea> Finish | Cancel |
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Visualisation View

The visualisation view acts as a point via which scenarios and their associated datasets are
presented in mapped form. This view auto populates after creating a scenario or having

successfully added data to the view. It may also be populated by right clicking the desired

S 3 B Gl O3

s

| BB

En 2

S|

scenario and selecting 2d or 3d renders.

[ AndreTest (2D-Swing) 7

BAOGERB/RA_/UEL PAav rd =0

FOQORFBRAEC AV pd =0 5
/ L o=
fs’eIECt Default \
eature :
il Zoom Pan tools
Fdit
Clear
Selection
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Data Catalogue View

09 Catalog 32 | dO gl =0
{3 Ergo EQ Demo Data (local)
[ Ergo-EQ Public Repository
{ Local Cache

[, UWI-DRRC Public Repository
@ ergo

Data Catalogue View contains a list of repositories to which the CaribEviz software is
communicating. Upon installation there is a possibility that you will only see Local Cache

within this view. To add other available repositories to the list, ensure that your device is

connected to the internet then click the add repository icon @ .

Trouble Shooting
java.lang.NullPointerException error: Software communicated with the repository but found

no data within the given file path. Solution: ensure correct path was chosen if yes close and

re-enter software.
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Style Editor

- P s s . ~

é-styie&ﬁ;-zé- : — i e ZJE f‘_’ i:) ==
Simple Style| Ranged Style| Unique Style| Rester Style

Unlike the three previous interfaces discussed, style editor will not automatically start when
the workbench is accessed. To assess this window, select Windows>Show View>Style
Editor. Using this tab display attributes for the datasets being displayed within the

visualization view can be modified to allow for better representation and viewing.

If at any time you need to reassess theses aforementioned windows you can do so by

selecting Windows>Show View>"window you which to populate”.
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Tutorials- Creating an Analysis
Building Structure Damage

Create a New Scenario,

Under Region Selector, select United States of America, and further select Tennessee State

followed by Shelby County.
Leave the final pop up window as the default setting. (Ergo 4.0.0 Beta 1).

You will now need to add buildings to the scenario. To do this expand Ergos repository
followed by buildings. Under building inventory V4 select Shelby County No SF. To select
you may choose to drag and drop the item over unto the visualization window or right click

the item followed by load dataset.

Also required for this scenario is the topographic information for the area. This can be found

in Topography>Digital Elevation Model.

.l
Select the execute analysis icon .

The analysis Tab should then populate with the various form of analysis available through the

software.
Select Building>Structural Damage

Ergo and thus by extension CaribEviz will not allow for the execution of analysis without all
parameters required for the analysis having been satisfied. You will therefore have to resolve

each parameter. Parameter that are properly defined will be highlighted in red.
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Execute Analysis

Please select an analysis...
Analysis Description
> o} Bridge

> [l Building

» ¥3¥ Decision Support
> @ GIS

» v Hazard

> ' Lifeline

» &8 Socioeconomic
> 99 Validation

Hep || Fnish | | Cancel

In order to develop an understanding of building structure damage, one must first define the
hazard to which the buildings will be subjected. In this scenario the hazard will be defined as
an earthquake. Click on the icon “create scenario earthquake”. Input the field as shown

below.

&y Create Scenario Eaﬂhquake All required fields must be completed

‘Required | Optional|
v B.asic.f;)f.omnllon

| Result Name: d

| Period Spectrum Method: B!St Match

: Attenuation: \ CEUS Characteristic Evert
|

|

= Earthquake Location

P Select from Source Event

& Select from USGS Latest Earthquakes
& Select by clicking on the map
Latitude (deg): 35927
Longitude (deg): -89.919
Magnitude: 79

© Depth(km): 100

|

i ~ Raster Display Information

1 Grid Points: 1025

Eug. Reset to region of interest

Nicnlaw Ractar piRAa [¥]
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Having inputted the fields the icon for create scenario earthquake should have now turned to

green.

Click on the icon for building structural damage then input the fields as indicated below. To
populate the fields, select search the left click the option that comes up. Once all field turn

green, you are then able to click on the execute analysis icon.

Note: file paths within the ergo repository and by extension UWI-DRRC public
repository are subject to change. If at any point in time an error is returned, select the

option that most closely relates to the values as seen below.

Q Exorute

Building Structural Damage
| © cancel Anabasis
Required Optional
= Basic Information

Result Name: structurs! damags

Buildings Shelby County Mo SF Busidings v v | | P search

@ Create Scenano Earthouake P search

Hazard @ Create
Bamove

~ Advanced Parameters
Use Hazard Uncertainty?:

| Include Liguefaction?

Fraginies: Defauit Building Fragilties L0 v | | Psearch
Frapiity Mapping Delaut Building Fragiity Mapping 1.0 v | | P search
Building Stock Uncenainty: 0.0

Building Stock Uncentanty Tolerance: 0.01
I Expected Value Building Damage Ratios v1.1 v | Psearch

Damage Method Default bt

® pulding Structural Damags Help,

e ——————— e
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CaribEVix - a x
File Edit Repots Dateset Scenaric Windew Help
@ Canibéve 21 L@ 8% 4 % 0 |2 sheby County 2D-5wing) | - Building Structural Damage (Shelby County) 11 EEigs-co
‘ @ AndreChest |
5 gwmt Y |82 Retrofit Cost Estimstion|
| 1
| » @ Charlesten County Tuterial =
e .
{ ity - :
| [} Region of interest: Shelby County, Tennessee 4
Bt e [—— (5 ez
| > @ Shelby Buildings
H @ Shelby Buildings (2) ’ ~
| @ Shelby County No SF ) Beate’ | & Cancel
@ Shelby Scenario
@ Shelby County Topography . - =
. @ Region of Interest £ saiect from USGS Latest Earthquakes
» (& Scenaric Deta r "

» [ Saved Analysis Workflows =
- ek Latitude (deg): | 35.927

Longitude (deg): -85.919
Magnitude: 78
Depth (kmi: 00

~ Raster Display Information

LI S Grid Points: 1025
— = —— e i ™ P
) Cetalog BLIBI% -~ O &mﬂmmm
L S i v
[ ErgeEQ Demo Dats (local) i PaLhEa
y : | 0.016750662305804555

(2, Ergo-EQ Public Repository Grid Spacing (deg): 0.01
|5 () Locsl Cache MinimumLst:  3495419547008284
| + [} UWIDRRC Public Repository | MinimumLong:  -S0.30988254814631
|0 ege ! Mudmum Lat. | 35.40839055813116

Maximum Leng:  -BR.EITRITES11615
» Advanced Parameters

\
\ |
1 .ﬁmmnmum -

B coikvis - & %
File Edit feports Dataset Scenario Window Help

@ CorictVie 13 Le|@l¥ex=0
| » @ AndreChest

;-Onr_mm I

| » @ Bridge

| » @ Chadeston County Tutorial

|| v @ Shelby County

| [™ Region of Interest: Shelby County, Tennessee

@ Shelby County No SF
3 @ Shelby Scenario
» @ Shelby County Topography
s @ Region of Interest
» (&> Scenario Data
(& Saved Analysis Workflows

| Canstog 13| A0 | g% ~= 0]
1 Ergo EQDemo Data (local)
| » [ Erge-EQ Public Repesitery
|5 [ Local Cache
(2 UWIDRRC Public Repository
0 ego
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Damages to building may also be non-structural and to an extent be quantified economically.
Below are two such analysis which may be produced by populating the fields as shown using

the search icon. The Hazard data having already been created in the previous analysis will be

available from the search field.

@ carbEvia
File Edit Reports Dataset Scenaric Window Help

@ CacibEVie 13 Lo EdH x O ||[77 shelby County (20-Swing) | v Building Structural Damage (Shelby County) 3= Building Non-Structurel and Content Dsmage {genenliced) (Shelby.

@ AndreChest I
==
|

= o *

®[=
=

™

410

(i I

@ AndreTest !
@ bridge
@ Charleston County Tutorial
~ @ Shelby County
[71 Region of Interest: Shelby County, Tennessee
~ @ Mappable Data
+ @ Shelby Buildings
3 4D Shelby Buildings (2)
. :mm&l‘: Damage (3) 3 Becize | 5 Cancel
) @ Shelby Scensric |
» @ Shelby County Topography | Buildings: | Sheiy Lounty No S+ V| | & Semrch
) @ Regicn of Interest z
Wi i | ] Sheiby Scensio Psouch
+ > Seved Analysis Workflows

mm

Use Hezard Uncertainty [m}
- - Inchude LiguelactionT: o
09 Catalog I A0 x b= Fragity: new test fragifity v P Sewch
{3 Ergo EQ Demo Data (local) . = .
[ Ergo-EQ Public Repository Fragiity Mspping: Building Fragility Mapping 247503 5a v
» [} Local Cache Buikding Stock Uncertainty: 00
[% UVA-DRRC Public Repository Buildinng Stock Uncertainty Tolerance: | 0.0)
0 e S Damage Facton Buitding AS Damege Factors vl [P seaecn
DS Damage Factor: | Building DS Damage Factors v | P semch
Cortent Damage Factor: Building Content Dsmage Factors v | P Sech
= v
CaribEViz - o x
File Edt Reports Datsset Scensrio Window Help
| @ CaribEviz £ L% 2| %4 %= O [ heby County 2D-5wing) 3= Building Structurs Dsmage (Shel.. |3 Building Non-Structural and Cont... |3+ Building Direct Economic Damsg... &2 = 0Ole
{5 @ AndreCheat SRR B EBzigD
| > @ AndreTest e
@ sie .
| 5 @ Charleston County Tutorial |
- L |
[ Region of Interest: Shelby County, Tennessee {
~ @ Mappable Data it 5 . .
T — [ |
) @ Shelby Buildings (2) I
» G Shelby Non Structursl Damage (3)
, @ Shelby County No 5F 2 Beate | © Coneel
. @ Shelby Scensric
y Sh C Tc » &
L Building Direct Economic Damage
(= Scenario Data
> Saved Analysis Workflows
Required | Opticnal

Building Damage: | Shelby Buildings (2) v [ Pseach| [ @ Create
= == = ——— - Advanced
9 Catalog 11 | 9CI@|lx ~=0 )
W{@]'_'_" -] Occupancy Demage Multigliers: | Building Occupancy Multipliers v | | P Search
+ 1 Erge-EQ Public Repository | )
» [ Local Cache ) Building Direct Economic Damage Helo
[, Uw1-DRRC Public Repesitery
11 erge

Eaecuting arabyss -
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(O - a8 X
File Edt Reports Detaet Scenaic Window Help ) ) ) )
@t C®| 2 94| X = 0| sheby oty 20-Gui. | Buibing Sructual .. |3 Buikfng Ko Sructrsl. |3+ Buiking Diveet Econom. [+ Fscal impact Shatby €. 28}~ 9 | #
. @ AndeChest 1 BEEe -8
» @ AndeeTest I
» @ Bridge
» @ Charleston County Tutorisl
~ (@ Shelby County
[\ Region of Intevest: Shelby County, Tennessee
v (@ Mappeble Data
> @ Shelby Buildings
) @ Shelby Buildings @)
» @ Shelby Non Structunl Demage (3)
@® Building Econcmic Damage
» @ Fiscol bopact |
‘:h—qmmv . Fiscal Impact !
» @ Shelby County Topography |
» @ Region of Interest |

| ;:,‘:Emuu | 5 Cancel

s G Scenario Dets Recpaired | Optional] |
) G Saved Anslysic Wordflows ResuktName: i
Direct Economic Damage: | Buil vl | Psemch | @ Creste :
Tax Rate(tey I ) e |
e A 1§ 1LY |
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Creating a Report

Rick Click on the Desired Model output under the scenario window, eg. Fiscal Impact-
>Show Reports

You will be prompted with two options, one for a detailed report and the other for a
Summarized version. Reports comprise of three components: a map of the dataset, a chart and

the associated attribute table.

B Caribéviz - 8 %
File Edit M‘ Dataset  Scenaric W'MN Help
@ CaribEviz 11 D@8 % 4] % = O sheby County 20-Sei_ |3 Bulding Sractursi D | |* Select Report View £
. @ AndreCheat ] NMWH |
. @ AndreTest -
@ Bidse '
» @ Cherleston County Tutorisl
~ @ Snelby County
[\ Regicn of Interest: Shelby County, Tennessee [0 Tox Rate Mag
~ @ Mappable Data
@ Shelby Buildings
» @ Shelby Buildings (2) |
< Shelby Non Structurel Damage (3) | ~
. @ Buikding Econormic Damage [ et R Cm |
@ Fiscal Impact |
@ Shelby County No SF l Required types: Any
@ sty ceur || st e . e
» @ Shelby County Topography |
» ‘G Regiom of nerest: | and char, and a summary data table
& Scenario Data || Remieed| Optional|
2= Saved Analysis Workllows | ResultMame Fiscal Impact @)
| Direct Economic Demage: |Building Econcmic Dam
1 Tax Rate(’s): 1
——— )| Brolmpsatice
0 Catalog &1 | 908w v=0
[ Ergo EQ Demo Dats {local) ‘
+ [ Ergo-EQ Public Repository
» [ Local Cache
.+ [ UWKDRRC Public Repositary
| 0o
i
L
1 report$E210TTE002383305.po - Adobe Acrobat Resder D - 8 X
File Edt View Window Help
Home Tools repon6142171271... report9692107759.. x (@ signin
B EQ @® 1 R MEOE - R BEAT @ L
Y
. Mid-America Earthquake Center (3 Export POF h
Ergo-EQ report: Shelby County « fthg
P B R R O . R R I v S S S Y Create PDF v
Fiscal Impact 52 Edit POF v
Comment
€0 combineFiles v

E[] oOrganize Pages v

» A Fill&sign

0-
C1 C2PCIPCZRM S1 S3 .. Wi W2 whe Send for Signature

® Property Tax Loss

~»- Send & Track

@ More Tools

FEREFTER

Store and share files in the
Document Cloud

Lea More
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If at any point you lose connection to the repository delete it then reconnect to it using
the sync repository option.

Ingesting Datasets

There is at present a wealth of datasets within both ergo and UWI-DRRC public repositories.
If however the need does arise for additional data set to incorporated and subsequently used

here are a few tips:

1. Creation of the data set must be done using appropriate tools eg. ARC GIS, Q-GIS.

2. When creating attributes for the data set ensure that the format of the table matches
formats as seen within the public repositories. This ensures that the software
communicates with the relevant path during subsequent analysis.

3. To impoert, selectGo to File > Import>Expand Data category and select Dataset, Click
Next.

4. Select the type of file followed by the file path. When prompted for data type select

the best suited folder eg. Building data should be ingested within Building Inventory.



